Window stays hidden when running zeus

If reporting a bug with the Zeus editor please post the details here. Please do not post questions here.
alexalex
Posts: 14
Joined: Thu Jul 12, 2007 9:16 am

Window stays hidden when running zeus

Postby alexalex » Tue Mar 25, 2008 11:49 am

Hi,

When I double click a file that associated with Zeus, the Zeus window get the focus of the keyboard and even the title bar indicates that Zeus is active, but it stays in back.
If you pay attention you can see that the window pops up and then pops back down.
This happens only if zeus is already opened and is not minimized in the taskbar.
Further more, it does not happen consistently. Several of the double-clicks happens to bring the Zeus up front and several of them don’t.

Thanks

AlanStewart
Posts: 77
Joined: Fri Jun 02, 2006 6:52 pm

Postby AlanStewart » Tue Mar 25, 2008 8:59 pm

I've noticed this as well. I just assumed it was my version of XP here at work since my home one doesn't do that. I do admit that "it's never done that before" and I have just recently upgraded to v3.96 (now on 3.96o). I'll have to keep an eye on this and see if there's anything consistent about this.

jussij
Site Admin
Posts: 2227
Joined: Fri Aug 13, 2004 5:10 pm

Postby jussij » Tue Mar 25, 2008 10:37 pm

When I double click a file that associated with Zeus, the Zeus window get the focus of the keyboard and even the title bar indicates that Zeus is active, but it stays in back.

No matter how many files I double click on in the Windows Explorer I can no replicate this bug :(

Which version of Windows are you running :?:

I am running Windows XP in classic mode.

Without some way to replicate the bug this is going to be very hard to locate and fix :(

Cheers Jussi

alexalex
Posts: 14
Joined: Thu Jul 12, 2007 9:16 am

Postby alexalex » Wed Mar 26, 2008 7:44 am

I am using Zeus version 3.95z, and windows XP professional version 2002 with service pack 2 installed.
Another input about this bug is that when I first installed Zeus it didn't happen, and on one day it started to appear. First I thought it is something temporary and I ignored it, even tried to reboot the windows, but now it is really annoying.

jussij
Site Admin
Posts: 2227
Joined: Fri Aug 13, 2004 5:10 pm

Postby jussij » Wed Mar 26, 2008 10:47 pm

Another input about this bug is that when I first installed Zeus it didn't happen, and on one day it started to appear.

If this worked when Zeus was first installed but then stopped working some time later, this suggest to me something else other than Zeus has created the issue :?

I know that over the years there have been many changes to Windows all designed to stop Windows programs from stealing the focus from other Windows programs, so it might be that a recent Windows update may well have introduced this new behaviour :?

But what is strange is I'm running a version of Windows XP that is pretty much up to date and for me I can double click files in Explorer and they all activate and load into Zeus just fine.

Cheers Jussi

AlanStewart
Posts: 77
Joined: Fri Jun 02, 2006 6:52 pm

Windoze

Postby AlanStewart » Wed Mar 26, 2008 11:47 pm

Yeah, that whole "Don't mind me while I just pop this window up over top of what you where doing. Oh, were you typing something? No mind, I'll just take whatever that was an apply it to this window? Oh, somehow I seem to have reset your login password to whatever random characters you were typing. Have a nice day!" thing is just a *WEE* bit irritating. But of course there's no simple solution.

I agree, I *think* it's something weird in Windows and I don't know if there's anything that Zeus can do to manage this. Maybe it's a matter of setting even more parameters when opening the window?

I can get it to be sort of consistent (but only sort of) when I do a "Send To" to send random files to Zeus. I do this instead of associating *every* text file with Zeus. That might be another thing to try.

jussij
Site Admin
Posts: 2227
Joined: Fri Aug 13, 2004 5:10 pm

Postby jussij » Thu Mar 27, 2008 12:09 am

I agree, I *think* it's something weird in Windows and I don't know if there's anything that Zeus can do to manage this.

The code that loads a file into Zeus from the explorer dates back to the days of Windows 3.x and back then the application had to bring itself to the top after loading the file.

But it may well that todays version of Windows is now blocking Zeus just because it is trying to bring itself to the foreground :?

I will run a few tests at this end to see if the code to bring Zeus to the foreground is now redundant, and if is, removing the code might fix the problem.

Cheers Jussi

jussij
Site Admin
Posts: 2227
Joined: Fri Aug 13, 2004 5:10 pm

Postby jussij » Mon Mar 31, 2008 11:51 pm

Could you please try the latest Zeus version found here: http://www.zeusedit.com/forum/viewtopic.php?t=1790

Since I could not replicate the bug myself, I am not sure if it is fixed by the patch or not :?

This latest version no longer attempts to activate Zeus after loading the file from explorer, so hopefully this will fix the issue.

Cheers Jussi

AlanStewart
Posts: 77
Joined: Fri Jun 02, 2006 6:52 pm

3.96oB

Postby AlanStewart » Tue Apr 01, 2008 4:51 am

For me the problem still persists. I installed the new patch over top of my existing Zeus (backed up first of course!) and opened Zeus back up. Then I used Send To to send files to Zeus and within 2 or 3 of them the problem appeared where the file would load but the Zeus window would disappear, even though the taskbar says that Zeus is active. Bummer. Maybe someone else can describe the problem in a way that helps?

jussij
Site Admin
Posts: 2227
Joined: Fri Aug 13, 2004 5:10 pm

Postby jussij » Tue Apr 01, 2008 5:29 am

Hi Alan,

Thanks for the feedback. Previously I had only checked the double clicking of files from within Explorer, so I tried to replicate this bug using Send To option from within Explorer.

But once again, I no matter how many files I "Send To", Zeus loads the files and activates correctly :(

So once again I am not able to replicate this on my version of Windows XP :(

Cheers Jussi

alexalex
Posts: 14
Joined: Thu Jul 12, 2007 9:16 am

Postby alexalex » Tue Apr 01, 2008 3:05 pm

Hi Jussi,

Thank you for the patch, but unfortunately I cannot apply it on my version. I have 3.95z.

But anyway, as I understand it didn't help Alan.

I think this is a Windows XP bug rather than Zeus bug.

Hope someone could post some useful information regarding this annoying phenomena.

Thanks
Alex


Return to “Reporting a Bug”

Who is online

Users browsing this forum: No registered users and 1 guest

cron