Bookmarks in Zeus 3.96 do not work

If reporting a bug with the Zeus editor please post the details here. Please do not post questions here.
HardyPill
Posts: 13
Joined: Wed Feb 09, 2005 12:58 pm
Location: Germany

Bookmarks in Zeus 3.96 do not work

Postby HardyPill » Tue Jan 16, 2007 1:01 pm

I'm using the BriefEx Keyboard Mapping. In Versions up to 3.95z if I press 'Alt' + '0' I can drop a bookmark, as I can see in the Status line. With 'Alt' + 'J' '0' I can jump to the previously assigned bookmark.
With Version 3.96 this didn't work :( . I cannot see the infromation about a dropped bookmark in the Status line, therefore I cannot say, if dropping a bookmark or jumping to a bookmark doesn't work. Anyway, if I press 'Alt' + 'J' the new bookmark dialog was opened, but there are no entries.

Please try to reproduce this and let me know, what's the problem...

Michael

jussij
Site Admin
Posts: 2230
Joined: Fri Aug 13, 2004 5:10 pm

Postby jussij » Tue Jan 16, 2007 10:00 pm

Hi Michael,

In Versions up to 3.95z if I press 'Alt' + '0' I can drop a bookmark, as I can see in the Status line. With 'Alt' + 'J' '0' I can jump to the previously assigned bookmark.

To return to this older functionality just remap the Alt+J key to the BookMarkGoto keyboard function ;)

Anyway, if I press 'Alt' + 'J' the new bookmark dialog was opened, but there are no entries.

I will see if I can reproduce this problem.

Cheers Jussi

HardyPill
Posts: 13
Joined: Wed Feb 09, 2005 12:58 pm
Location: Germany

Postby HardyPill » Wed Jan 17, 2007 10:40 am

Hi Jussi,

I did the old assignment for 'Alt' + 'J' and the known dialog asks for the bookmark number...
But it seems that dropping with 'Alt' + '0'/'1'/... doesn't work: If I try to goto a dropped bookmark, I get the error message in the status line: No bookmark dropped at this location.

Furthermore I hope that I can get an update to 3.96 for free because I bought the 3.95z only 3 weeks before the 3.96 was launched. :wink:

Best regards
Michael

jussij
Site Admin
Posts: 2230
Joined: Fri Aug 13, 2004 5:10 pm

Postby jussij » Fri Jan 19, 2007 2:15 am

Hi Michael,
Furthermore I hope that I can get an update to 3.96 for free because I bought the 3.95z only 3 weeks before the 3.96 was launched.

The Zeus upgrade page is now finally working :)

For the upgrade pricing details refer to this link: http://www.zeusedit.com/forum/viewtopic.php?t=1033

Cheers Jussi

jussij
Site Admin
Posts: 2230
Joined: Fri Aug 13, 2004 5:10 pm

Postby jussij » Mon Jan 22, 2007 10:13 pm

The latest Zeus for Windows 3.96a patch fixes this problem :)

Refer to this link for more details: http://www.zeusedit.com/forum/viewtopic.php?t=1035

Cheers Jussi

HardyPill
Posts: 13
Joined: Wed Feb 09, 2005 12:58 pm
Location: Germany

Postby HardyPill » Wed Jan 24, 2007 9:02 pm

Hi Jussij !

I installed the patch 3.96a - but the behaviour with the bookmarks was unchanged !!! :cry:
Please check it again !

Michael

codeguy
Posts: 11
Joined: Tue Aug 22, 2006 5:45 pm

Postby codeguy » Fri Jan 26, 2007 4:20 pm

Hi Jussi,

I too am having problems with bookmarks. I have the 3.96a eval, and I copied over my old zConfig folder.

I cannot get bookmarks to work at all. I have Alt-1 mapped to DropBookmark1, but it wont drop. I have Ctrl-1 mappged to GotoBookmark1, and it reports "No bookmark set at this location".

Otherwise... Looks great!

-Andy

jussij
Site Admin
Posts: 2230
Joined: Fri Aug 13, 2004 5:10 pm

Postby jussij » Sun Jan 28, 2007 10:50 pm

I cannot get bookmarks to work at all.

Unfortuately I can not replicate any of these issues :(

For me the BookMarkDrop1, BookMarkDisplay and BookMarkGoto keyboard functions all seem to be working fine :?

I did notice the bookmarks do go wrong if sections of code are folded away, but I am pretty sure this was an issue will all versions of Zeus and not just this latest version.

Cheers Jussi

jussij
Site Admin
Posts: 2230
Joined: Fri Aug 13, 2004 5:10 pm

Postby jussij » Wed Feb 28, 2007 10:36 pm

Bookmarks should now be working in the latest Zeus patch: http://www.zeusedit.com/forum/viewtopic.php?t=1064

Cheers Jussi


Return to “Reporting a Bug”

Who is online

Users browsing this forum: No registered users and 0 guests

cron